/ SAE

WordPress移植SAE之禁用更新

SAE平台是禁用本地IO的,所以是不支持WordPress的自动更新,包括内核、插件和主题的更新。

但是WordPress默认是会自动检查更新,这样会消耗应用资源(流量和cputime),造成云豆的浪费,所以要把检查更新的功能去掉。

但是这样又有一个问题,万一有个插件有BUG需要更新,没有了自动检查更新就无法知道某个插件是否有更新,所以还要保留手动检查更新的功能。

需要修改的文件在wp-include/update.php

在这个文件的末尾,把所有的add_action注释掉,然后添加以下代码

add_action( 'load-update-core.php', 'wp_version_check' ); add_action( 'load-update-core.php', 'wp_update_themes' ); add_action( 'load-update-core.php', 'wp_update_plugins' );

这样就变成在用户点击“仪表盘”→“更新”时才检查更新。

WordPress移植SAE之禁用更新
Share this