WordPress语法高亮增强插件更新至2.3.0版本

Wordpress语法高亮增强插件(SyntaxHighlighter++)今日更新至2.3.0版本,主要改动如下: 动态加载js

1.将语法高亮内核回滚至2.0版本。 WordPress

2.保留了3.0版本的Autoload方式动态加载js库,减少加载的js文件数量,加快页面访问速度。

3.合并了CSS文件,减少页面加载时间。 语法高亮

Wordpress官方下载地址:http://wordpress.org/extend/plugins/syntax-highlighter-with-add-button-in-editor/ 动态加载js

本站下载:语法高亮增强插件2.3.0

syntax-highlighter++

《WordPress语法高亮增强插件更新至2.3.0版本》有71个想法

  1. 我试用了一下这个插件,学得很不错,但是还有一些不习惯的地方,比如,我嫌插件目录的名称实在是太长了,还有我平时用不到那么多的语言,所以我改了下插件的目录名,再调整了一下语言的排列顺序,但是这样一来,wordpress总是提醒我有新的版本,要让我自动升级,我怕一升级,把我的自己的修改给覆盖了,我只好再把插件名称也改了。
    希望原作者可以见谅。

  2. 我原来是用SyntaxHighlighter Evolved,可是最近不知道怎么搞的,它竟然不能自动换行了,长代码一直溜到页面以外…目前在用你的这个,感觉很方便.特来感谢.

          1. 因为跟服务端主题有点冲突,我把它改成了code标签.可是新发表的文章还是没有高亮.插入代码后查看HTML源码,发现依然使用的是pre标签.是不是这个标签有使用限制?或者我哪里操作错了.本地环境是3.4,服务器端环境是3.3.1

          1. 效率好快,这就更新.貌似还是有点小问题.更改为其他标签后(如:code),虽然编辑器里的标签也变成了code,但是在阅读文章时,代码并没有高亮.使用自带的主题同样问题.区别就是它在首页完整显示文章时会高亮.另外非wordpress标签(如:code1,pre1),插入代码后,未在HTML发现任何代码标签,即丢失标签.是不是设计就是这样,只能用更改为code,div之类标签,不能自定义code1之类标签.另外,我的问题是不是太多了…

        1. 第一个问题在我博客测试是正常的,在首页和文章页面都是高亮的。第二个问题应该是WP系统的过滤,会自动把不合法的标签移除。

          1. 不会跟本地浏览器有关系吧,win7+IE8+chrome19.问题网页http://blog.twohuo.com/1231231232.html.如果可以,希望能帮忙看看.已使用WP3.3.2的自带主题,标签设置为code,首页会高亮,但是代码格式会被改变,后台插入代码后不会像使用默认pre标签一样背景变成灰色.首页加载有点慢…

  3. 所以有点奇怪.是不是跟空间有关,我的空间是PHP+Linux,本地是Win7+php,貌似你的是asp.我在本地(XAMPP 1.7.7)直接安装wp3.4,然后安装插件,该标签为code,然后发代码,依然无法高亮.

      1. 偶又来了.照样说问题.应该叫改进.
        1.貌似空代码,点”插入”,也会将标签插入到文章中…插入的时候是否可以if一下?
        2.使用code标签似乎会和很多主题冲突,比如hotnewspro 2.7plus,weisay simple导致文章叶排版混乱,可是自带主题却没这个问题…

  4. 首先非常感谢博主提供了这么好的插件!
    但在我博客上使用过程中,我发现这款代码高亮插件的行号有时显示不出来或者行号右边会多显示一些像按钮之类的东西,不知道是不是CSS代码与我主题冲突的原因。

    1. 首先添加Objective-C的高亮规则,放在scripts目录下,格式参考其他语言。然后修改syntaxhighlighterpp.php文件,查找SyntaxHighlighter.autoloader.apply,加入你添加的高亮规则文件名。最后查找<select id=”language”>,添加Objective-C项即可。

  5. 我以前一直用Syntax Highlighter Optimized这个代码插件,现在可能和我的主题有关或者是WP太新,不好用了
    刚用上老大你的这个插件,但在我的主题下有个显示问题:
    我的单篇文章页面的右上角有一块区域是显示相关文章,代码会覆盖这个区域。
    应该是这个插件去取文章页面的宽度值了,而没有考虑到这个相关文章区域。
    应该怎么解决呢?
    效果:http://penpenguanguan.com/1637.html

  6. 可以在编辑器栏里面加一个按钮,然后弹出代码窗口进行黏贴代码吗?

    感觉直接放在下面不怎么规范啊。。

    拜托了。

    最好可以自由切换,迎合所有人的需求。

  7. 在几个博客上看到推荐这款插件,于是就过来看看,真的很棒,而且只有200K,我用的其他的最小的都1.4MB了。解决了换行,滚动条,代码转义等一系列问题!果断换成这款!
    可以在可视化编辑器和HTML下自由切换,插入代码后光标跳出代码区,且可以自由定位,不像很多插件,插入代码后光标挪不出来。谢谢博主的开发!

    另外,博主您好,我想请教下,如何在WordPress默认的编辑器上集成插入代码的按钮呢,因为我的文章评论调用了编辑器,希望前台用户也能方便的使用它插入按钮。请指点一二,谢谢了!

    在线等……常关注!

      1. 博主这么晚还没睡哈!是这样的,我刚才在评论页面调用了这个代码插入框,但是插入代码并不会提交到编辑器输入框中,不知道这个好不好解决,我不会弄。呜呜呜。

  8. 问题反馈:

    我发现这个Syntax Highlighter++插件有问题,在进入“媒体库”→“编辑”图片页面会出现空白,建议您尽快抽空修复编辑图片页面空白问题。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

您必须启用 javascript 才能在这儿看到验证码!